=================
== Mike Clarke ==
=================

Logging the MikroTik LTE setup process

Today I used the setup I built in the previous lab to capture the setup process for the MikroTik R11e-LTE6 modem.

Very little configuration is required for this in RouterOS.

  1. The first step is to configure the APN details for your mobile carrier. APN profiles are first-class objects in RouterOS, to allow them to be independently attached to and detached from interfaces and SIM slots without losing the configuration.
/interface lte apn add name=vodafone apn=pp.vodafone.co.uk user=wap password=wap
  1. Attach this new profile to the only LTE interface
/interface lte set lte1 apn-profiles=vodafone
  1. Wait for a little while and confirm you can ping out to the world:
/ping 1.1.1.1
  1. Once you have confirmed that the LTE interface is working, configure the system logger to log LTE commands, then reboot so the log will show the full setup process from a clean boot.
/system logging add topics=lte
/system reboot
  1. Wait for the system to reboot and establish a connection again. Once you’re connected configure your serial terminal to log serial traffic to disk, and then dump the RouterOS log to the console with /log print.

If all has gone well you should now have a full log of the interaction between RouterOS and the modem during the boot and connection process.